Website Issue
Incident Report for PartydoosMedia
Resolved
The issue has been resolved, thank you for your patience.
Posted Nov 10, 2020 - 16:04 UTC
Investigating
We currently have an issue with our website, being that it redirects to viruses. We're investigating the issue.
Posted Nov 10, 2020 - 15:51 UTC