Password Recovery not working
Incident Report for PartydoosMedia
Resolved
This incident is resolved, we thank you for your patience.
Posted Nov 27, 2020 - 20:27 UTC
Investigating
Currently, the 'Password Recovery' doesn't send the actual emails. If you forgot your password, please contact support through support@partydoosmedia.com and we'll assist you further!
Posted Nov 27, 2020 - 20:16 UTC