Recent Website Outage(s)
Incident Report for PartydoosMedia
Resolved
This incident seems to be resolved. Thanks!
Posted Feb 19, 2021 - 21:13 UTC
Identified
We are aware of the recent downtimes of our website and know the reason for it. We're seeing how we can resolve this as soon as possible.
Posted Feb 19, 2021 - 20:58 UTC
This incident affected: Website, Services, Account Features, and Mail Servers.